[Linux-bruxelles] imprimante de s'installe pas :

dstc dstc at skynet.be
Mer 10 Juin 14:40:39 CEST 2020


bonjour carl
drt at stg:~$ sudo
[sudo] Mot de passe de drt :
sudo: /etc/init.d/cupsd : commande introuvable
drt at stg:~$ sudo /etc/init.d/cups-browsed start
[ ok ] Starting cups-browsed (via systemctl): cups-browsed.service.
drt at stg:~$
en cherchant sur ~$ ls -l /etc/init.d on trouve cups tout court
~$ ls -l /etc/init.d/cups
-rwxr-xr-x 1 root root 2804 mar 27  2018 /etc/init.d/cups

:~$ sudo /etc/init.d/cups start
[ ok ] Starting cups (via systemctl): cups.service.
drt at stg:~$
~$  sudo /etc/init.d/cups-browsed start
[ ok ] Starting cups-browsed (via systemctl): cups-browsed.service.

il y a du progrès : quand je lance "imprimer" sur un fichier libreoffice 
ouvert, la fenêtre "imprimer" apparaît avec les menus "général, mise en 
page, options", mais quand on pousse le bouton <imprimer> il ne se passe 
rien, et lorsqu'on va "menu=>administration=>imprimante" le jeux des 
trois fenêtres successives apparaît.
je suis persuadé qu'il y a un bug dans cette nouvelle version de 
linuxmint 19,3, j'ai meilleur temps à refaire une installation avec une 
version antérieur lm 18,3.
je préfère consacrer mon temps à des clefs multisystème et des disques 
multi boot
merci de ton aide.
phdh




Le 9/06/20 à 22:20, Carl a écrit :
> On 09/06/2020 21:55, philippe-dehenau wrote:
>> bonsoir,
>> merci du renseignement,
>> :~$ ps aux | grep cups
>> drt       3116  0.0  0.0  15660  1000 pts/2    S+   20:50   0:00 grep
>> --color=auto cups
>>
>>
>> ~$ ls -l /usr/sbin | grep cups
>> lrwxrwxrwx 1 root root      10 avr 24 16:42 accept -> cupsaccept
>> -rwxr-xr-x 1 root root   10232 avr 24 16:42 cupsaccept
>> -rwxr-xr-x 1 root root   10232 avr 24 16:42 cupsaddsmb
>> -rwxr-xr-x 1 root root  178592 mai  9  2019 cups-browsed      # il y est
>> -rwxr-xr-x 1 root root   10232 avr 24 16:42 cupsctl
>> -rwxr-xr-x 1 root root  432712 avr 24 16:42 cupsd             #aussi
>> lrwxrwxrwx 1 root root      10 avr 24 16:42 cupsdisable -> cupsaccept
>> lrwxrwxrwx 1 root root      10 avr 24 16:42 cupsenable -> cupsaccept
>> -rwxr-xr-x 1 root root   26920 avr 24 16:42 cupsfilter
>> -rwxr-xr-x 1 root root   27911 fév 10  2018 cups-genppdupdate
>> lrwxrwxrwx 1 root root      10 avr 24 16:42 cupsreject -> cupsaccept
>> lrwxrwxrwx 1 root root      10 avr 24 16:42 reject -> cupsaccept
>> :~$
>> :~$
>> :~$ /usr/sbin/cupsd -l            # avec -l ça donne rien
>> :~$
>>
>> donc chez moi je ne retrouve pas la commande "grep cups"
>> ni "cupsd ou cups-browsed"
>> or ces fichiers existent.
> 
> C'est sans doute parce que les démons ne tourne pas : essaie de les lancer.
> 
> Chez moi (Debian), ça marche comme ceci :
> sudo /etc/init.d/cupsd start
> 
> Et ensuite :
> sudo /etc/init.d/cups-browsed start
> 
>> avec ps ne devrais-je pas aussi voir les pilotes epson ?
>> or ils n'y sont pas.
> 
> Je ne pense pas que tu devrais les voir : ps est la commande pour voir 
> quel processus tournent. Je pense que le pilote est appelé par le démon 
> cupsd, et que donc il n'apparait pas.
> 
> Mais je peux me tromper.
> 

-- 
--------------------------------------------
La banque éthique pour le future :
NewB :  www.newb.coop ou www.jeprendspart.be
--------------------------------------------



Plus d'informations sur la liste de diffusion Linux-bruxelles