[Linux-bruxelles] Php 7.1

Patrick Depuydt patrick at htag2.com
Mar 5 Déc 10:24:51 CET 2017


Petite question, je vois tout le monde n’utiliser que Ubuntu. 

Je m’interroge sur le pourquoi vous utilisez tous Ubuntu (qui pour moi est le Windows des Linuxiens, c’est dur mais c’est vrai, les gens font n’importe-quoi avec, bref…) ?

 

Est-ce le manque de connaissances qui vous empêche d’utiliser des distros plus « propres », soit plus pour le monde de l’entreprise genre n’importe-quel dérivé de RedHat (soit, Scientific Linux, CentOS, …) ?

 

Quel est cet engouement pour la distro la plus mainstream qui au final risque de vous imposer un carcan identique à un OS non-libre ?

 

Genre ma solution à ce problème serait : CentOS + EPEL + Remi et le tour est joué…

 

Mais bon, j’aimerais comprendre pourquoi cet attachement à Ubuntu… ?

 

-- 

Patrick Depuydt

#2 –  IT Service Manager

24-26 Deschampelheerstraat 1081 Brussel

Mobile: +32 (0)484 42 41 37

info at htag2.com

 

From: Linux-bruxelles <linux-bruxelles-bounces at lists.bxlug.be> on behalf of PARISEL Jérémie <jeremie at parisel.net>
Reply-To: <linux-bruxelles at lists.bxlug.be>
Date: Monday, 4 December 2017 at 17:31
To: <linux-bruxelles at lists.bxlug.be>, Manuel Schulte <manuel.schulte at gmail.com>
Subject: Re: [Linux-bruxelles] Php 7.1

 

+1 

J'ajouterais la
c. Tu prends une Ubuntu Server 17.10 (non LTS, donc) et dans 5 mois tu dist-upgrade (enfin, do-release-upgrade en langage Ubuntu) et tu changes ton canal d'upgrade à LTS ( c'est juste un fichier à modifier). Peut-être mieux vaut-il attendre la 18.04.1 pour être sûr que la LTS ait fait ses maladies de jeunesse.

C'est pas tip-top mais ça permet quand même de déployer aujourd'hui quelque chose qui sera suivi 5 ans et de pas devoir jouer avec des dépôts dont la pérénité n'est pas assurée (quoique je vois le nom de Ondřej Surý - le gars derrière le PPA- depuis pas mal d'années).

Voilà pour mes 2 cents,

Jérémie

 

 

Le 04/12/17 à 13:28, Manuel Schulte a écrit :

Ben t'as pas 50 solutions:

 

a. Si php7.1 n'est disponible dans aucune disto "LTS", tu pars du principe que le niveau de maturité n'est pas là et donc tu t'interdis l'usage de cette version tant qu'elle n'a pas intégré une version LTS (ou équivalente) de ta distro de référence.

 

b. Tu montes un serveurs spécifique en LTS avec le dépôt alternatif, tu valides le fonctionnement et si c'est ok, tu fais avec en attendant que ta version de php tombe dans les dépôts de ta distro LTS de référence.

 

Et si php7.1 est nécessaire pour utiliser le framework Symphony 4.0, tu dois considérer aussi ce framework comme pas encore prêt pour une utilisation en production...

 

A++


Manuel SCHULTE 

Managing Director, Olympus Consulting sprl

gsm : +32(0)498 881 718 

mail : manuel.schulte at olympusconsulting.eu

web : http://www.olympusconsulting.eu/

 

Le 4 décembre 2017 à 12:48, Alain Belkadi <xigulor at linuxbeach.be> a écrit :

On 2017-12-04 12:29, Eric Hanuise wrote:

même problème au boulot, on a résolu ca en utilisant un repository externe (un ppa)

 

Oui ... mais c'est justement ce que je ne veux pas, même si je suis bien conscient que ça fonctionne très bien.

 

-- 

[Alain Belkadi / LinuxBeach]


_______________________________________________
Linux-bruxelles mailing list
Linux-bruxelles at lists.bxlug.be
https://listes.domainepublic.net/listinfo/linux-bruxelles

 




_______________________________________________
Linux-bruxelles mailing list
Linux-bruxelles at lists.bxlug.be
https://listes.domainepublic.net/listinfo/linux-bruxelles

_______________________________________________ Linux-bruxelles mailing list Linux-bruxelles at lists.bxlug.be https://listes.domainepublic.net/listinfo/linux-bruxelles 

-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...
URL: </pipermail/linux-bruxelles/attachments/20171205/0dd88adf/attachment-0002.html>


Plus d'informations sur la liste de diffusion Linux-bruxelles